Can't Use Merchandise Store

Have Been trying to purchase the stable in promotions, it goes to checkout and then gets stuck loading on the purchase confirmation.

[Please close thread issue resolved]

10/10/2019 9:13:00 PM #1

Others are still experiencing an issue of the site not connecting to xsolla.

I just tried buying something.

.....and then I'll smash it with a hammer!!!

10/10/2019 9:21:31 PM #2

Was having a problem on my pc but it worked fine on my phone so you guys can always try that.

10/10/2019 11:52:49 PM #3

I had problems on both. However, eventually it worked.

That seems to be a reoccurring theme too for those that have had difficulty. Eventually, it worked.

.....and then I'll smash it with a hammer!!!

10/11/2019 2:13:08 AM #4

So, basically I should just keep trying then.....

10/11/2019 2:14:38 AM #5

Have tried numerous times on different browsers. Cleared the browsers and restarted them. Nothing

15 minutes now and nothing

NA-E Luna Locked --------------------------------------------------

10/11/2019 2:30:25 AM #6

Same here team, tried android and PC. I will now try black magic.

You cannot have life without death. I create death, therefore I create life.