Town Name Stuck

I claimed my town and submitted a name. I had a weird problem with the naming process outlined in the link below.


That problem is now fixed, but my town name is the default and there is no indication of my choice having been rejected and no option to submit another name.

10/9/2019 3:10:00 AM #1

I'm having this problem with my settlement too :( Still says the default town name w/o any indication of waiting or if the name was approved/denied.

10/9/2019 3:27:27 AM #2

When you go to the map viewing page there is a quill on the right with a paper. That is where you see your name pending and or rename if you’re able to.

10/10/2019 2:39:57 AM #3

Doesn't exist on the page:
Image from Gyazo

10/10/2019 4:02:27 AM #4

Hmm. That is very strange. I have checked my accounts and it’s there for all of them including on mobile. Have you tried clearing your cache?

Firefox isn’t really supported. So I would try chrome btw

10/11/2019 12:31:57 AM #5

Tried Firefox, Chrome & even the dreaded IE after clearing cache. Same result