COMMUNITY - FORUMS - TECHNICAL SUPPORT
Problems with Claiming
+0

I can't claim my Bloodline package. it is loading and loading for Hours.


2/17/2019 9:39:22 AM #1
-1

And you don’t have a package currently on your account correct? Just the bloodline in your inventory?


2/17/2019 9:46:26 AM #2
+0

yes that's correct


2/17/2019 10:06:54 AM #3
+0

Have you tried it from a different browser? Or different internet? Maybe try mobile?


2/17/2019 10:09:56 AM #4
+0

I have tried Different Browsers and Mobiles and even Different Pc´s


2/17/2019 10:11:18 AM #5
+1

Hmm. Unfortunately I can only assist so much from the forums. My best suggestion to you is to email support from the email connected to your account with the detail you’ve provided here so they can assist you better. [email protected]


2/18/2019 9:14:18 PM #6
+0

We have investigated and found the issue. If all goes well we'll deploy the fix here shortly.

Thanks for your patience!


"Stupid questions make more sense than stupid mistakes."

2/19/2019 1:48:24 AM #7
+0

This should now be resolved, thanks for your patience!

Let us know if you encounter any other issues.

Thank you.


"Stupid questions make more sense than stupid mistakes."